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Introduction 

 

Rapid growth and development of Information Technology (IT) characterizes 

today's society. As a result, we have grown to depend on the knowledge and 

competence of an individual in the IT field. And although this dependence is 

growing from day to day,  the human right to education and information has not 

been extended to the IT field. Problems, that impact our society as a whole, 

create obstacles and distance people from the main reason and motivation for 

advancement, from the opportunity. 

Being computer illiterate in today's world means being someone who is unable to 

participate in modern society. It also means not to have opportunities. Despite 

the recognition of the European Commission, UNESCO, OECD and other relevant 

institutions on the necessity and benefits of computer literacy, there are still 

groups of people with hindered access to basic computer education (e.g. people 

with physical disabilities, people with learning difficulties, immigrant workers, the 

unemployed, people living in remote places where education is not accessible).  

This Manual, together with additional material published on Itdesk.info website, 

represent our contribution to the realization and promotion of human rights to 

education and information in the IT field. We hope that this education will help 

you to master basic computer skills and in this hope we wish that you learn as 

much as possible and become an active member of the modern IT society. 

Sincerely yours, 

ITdesk.info team  
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1. WEB CONCEPTS 

1.1. Key Terms 

1.1.1. Understand that the Internet supports a range of services such as the World 

Wide Web (WWW), File Transfer, email, instant messaging (IM) 

The Internet or "the network of networks" is a public network that connects computers 

and computer networks around the world through a common protocol (IP).  

All connected computers and networks mutually exchange information and use various 

services. Hence, the Internet is not solely the WWW, or pages and content available from 

a browser. In fact, the WWW is just one of the services that the Internet offers to its users 

although it is the most commonly used service. 

Other available services:  

File transfer - the file transfer from one computer to another. 

ü E-mail (electronic mail) ɀ it is the oldest Internet service, and it enables the 

exchange of digital messages between two or more people. 

ü  Instant messaging (IM) ɀ it enables the exchange of electronic messages between 

two or more people in real time. Such as chat rooms (Gtalk, MSN, Skype, etc.) that 

also support nowadays video/ audio/ photo communication exchange. 

 

1.1.2. Understand the term client/server. Understand the functionality and 

relationship between the browser and the web server 

The Internet is probably the best-known example of a client/ server relationship. The 

difference between a client and a server is big. Here we have two computers/ programs 

where the client sends requests to a server, and the server processes requests and 

returns the results to the client. A server is typically a remote computer not visible to the 

user. 

ü Web server: is the computer/ server whose entire content is visible on a website in 

a web browser. Web servers are constantly connected to the Internet. We access 

them through URL. Therefore, if we enter, for example, www.google.com in a 

web browser, we are accessing the Google server. 

ü Web browser: enables browsing through websites. Its mechanisms display the 

content, retrieved from the server, in a correct and understandable way.  As such 

it is an intermediary between the user and the server. (e.g. Google Chrome, 

Firefox, Internet Explorer, etc.) 

 

 

 

 

http://www.google.com/
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1.1.3. Understand the terms domain, Uniform Resource Locator (URL), hyperlink, 

web hosting, search engine. 

The domain is a unique name on the Internet. We might say that what in real life the ID is 

for a human, this is what the domain name is for a web page. 

 

URL (Uniform Resource Locator) is another term for a web address. A URL has three 

parts: 

ü protocol name (e.g., HTTP) 

ü domain name/ hostname (servers address that a user wants to connect with), for 

example, www.google.com 

ü file name is optional, implies the access to a file/directory into the principal 

webpage. It is separated by slash 

Therefore, when we enter http://www.google.com in the address bar in our web 

browser, the browser is instructed to connect to a server with the domain 

www.google.com by using the HTTP protocol. 

Hyperlinks are separately marked words, images and other elements on a web page that 

represent a direct link to additional information. Most often we open other web pages 

when we click on hyperlinks. Furthermore, we also might be able to open other parts of a 

web page, download content, and run applications. 

The image below shows a hyperlink, which is usually marked blue in texts and sometimes 

underlined to stand out. 

 
Web hosting: after we create a website, it is necessary to store it in a place where it is 

always available for users. We use Web hosting services/companies for this purpose. They 

own web servers that have the ability to store content. 

Search engine: Search engines allow us to search in the Internet for information, images 

and other types of files stored in various locations available throughout the network. 

Search engines work according to certain algorithms that show the user relevant, 

requested search results. At first, information from the various websites is collected and 

stored and then analyzed to organize and save them in the database for future use. When 

a user enters an inquiry into the search engine, the database is organized by an index and 

the user is presented with results that match best the entered search terms. Therefore, it 

http://www.google.com/
http://www.google.com/
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is important to understand that by using the search engine one does not search the entire 

InÔÅÒÎÅÔ ÂÕÔ ÔÈÅ ÓÅÁÒÃÈ ÅÎÇÉÎÅȭÓ ÄÁÔÁÂÁÓÅȢ 

Therefore, we might get different results each time we use different web engines. This 

information is important from a website ownerȭÓ ÖÉÅ×, who wants to make sure that the 

website is represented in various search engines once he created it. Otherwise, it will only 

be possible to access the website when a user enters the exact address in the web 

browser address bar. Currently, the most known search engine is ȰGoogle.ȱ 

1.1.4. Understand the use of primary protocols: Transmission Control Protocol/ 

Internet Protocol (TCP/lP), Hypertext Transfer Protocol (HTTP), File Transfer 

Protocol (FTP) 

TCP/IP proto col: TCP / IP: This protocol is the main protocol for Internet communication. 

It defines the rules that computers need to follow to communicate with other computers 

via a network. 

TCP is responsible for separating messages. They are then send across the network in 

smaller packets (packages). They reassemble again at the destination to present the 

initially sent message. This means that a sent eɀ mail, for example, does not travel 

through the network in one piece. It breaks down into smaller parts that travel separately 

through the network, not necessarily through the same channel, and then reassemble, 

according to the information that each packets carries, at the destination. Each packet 

includes information to which address it should travel (IP address). It is namely the IP 

protocol that is responsible for each packet to arrive at their destination.  

 

HTTP (Hypertext Transfer protocol): is a network protocol that ensures the exchange of 

almost all types of resources on the web. With resources, we mean files, pages, images, 

search results, etc. It is basically, the web browsers language to send requests to the 

server. There is also the HTTPS version, which is a secure and encrypted version for HTTP 

communications. 

FTP(File Transfer Protocol): is used to load (upload) or retrieve (download) files between 

the client and server communication, or between two computers on the Internet. In 

other words, this protocol is responsible for file transfer on the Internet. 
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1.2. Web Publishing 

1.2.1. Identify  the main advantages of having a website: access to a global audience, 

ease of updating, audience interactivity and cost savings. 

Nowadays more and more people/ companies opt to own a website. Positive sides of 

creating and having a website are: 

ü It is possible to reach a broad audience in an easy way. 

ü It is possible to change information from virtually anywhere in real time. If, for 

example, a website offers some products, it is possible to update prices with just a 

few clicks. 

ü Web sites allow a much better relationship with customers compared to 

conventional printed materials or advertisements on television or radio. The user 

can receive information more easily, answer questions, share experiences on a 

forum (if the page has one), etc. 

ü Maintaining a website is far less expensive than advertising on other media. 

Therefore, an online business can significantly reduce costs for staff, office space, 

etc. 

ü Obtain information of their constumers and create a specific target of their 

promotion 

 

1.2.2. Understand the process of putting  a website online: domain registration, selecting 

a web hosting service. 

The process of putting a website online consists of several steps: 

ü Once we create a web page, it is necessary to register a domain, register a unique 

name that will represent the web page on the Internet. When choosing a domain 

name one should preferably take into account that the domain should not be too 

long, it should be constructed well, and customers should be able to remember it 

easily. 

ü We did not reserve a spot for the webpage on the Internet by registering a 

domain, but we have only defined ÔÈÅ ×ÅÂÓÉÔÅȭÓ address. The next step is selecting 

a web hosting service or finding a company that offers servers to host a web page. 

There is a wide range of hosting providers and it is the website ownerȭÓ ÄÅÃÉÓÉÏÎ to 

choose a service that suits him the best. 

1.2.3 Recognize search engine optimization techniques e.g. including relevant 

metadata, including a sitemap and website links, registering with a search 

engine. 

Search engine optimization techniques serve to increase the probability that exactly your 

website ranks at a higher position among existing search results. In fact, it is the web 

results on the first few pages that will be visited the most during a web search. The 

further we look so decreases the results credibility, and thus the attendance of such 

websites decreases. 

Some of the available techniques are: 
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Including relevant metadata: metadata is used to list websiteȭs relevant data. This data is 

not visible on the webpage, and their task is to provide relevant data to help search 

engines index web pages easier, which means they help search engines in ranking web 

pages. 

The basic syntax is: 

 

 
Meta element names, then contain the author's name, website description, and 

keywords linked to the web page content. 

Including site maps and web links: a sitemap is a list of all the pages that a web page 

contains. By including site maps, we make sure that all web pages are registered to the 

search engine. 

Registering to a search engine: as stated above, it is not enough to simply develop and 

publish a page, but it is necessary to inform search engines that the web page exists. 

Some of the options that Google offers are for example: 

ü Add your URL -  URL adding 

ü App crawling - indexing 

ü Search Console- registering site maps 

 

1.2.4 Recognize the factors that impact web page download speed: audio, video, 

graphical objects, animation content, and file compression 

If the page contains, in addition to the text, a variety of other components such as video, 

sound, animation, etc. it affects the web page uploading speed. If we select these 

components in the wrong format, or if the page is overloaded with content it can lead to 

a slower web page download. The web page download speed is crucial to ensure a 

positive user experience, and it becomes even more important with the increasing mobile 

device use. 

When selecting the size recommendations are as follows: 

ü Audio - .mp3 format 

ü Video - .flv format 

ü  Graphic formats - .jpg picture in general, GIF, and PNG for images with few colors 

such as background images. 

Data compression also affects the web page download speed. The recommendation is to 

compress HTML and CSS files before putting them on a web server, in order to reduce 

their size, and thus increase the webpage download speed. 
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1.3 Legal Issues 

1.3.1. Understand the term copyright and its implications for  text, images, audio, 

and video available on websites 

 

It is a fact that we can easily download many contents from various websites. However, 

this does not mean that we can further use all website content. Quite contrary, in most 

cases content is under certain copyright rules. It is only possible to use content from 

another website freely if the website explicitly states it ɉȰÏÐÅÎ ÃÏÎÔÅÎÔȰȟ Ȱ/ÐÅÎ 3ÏÕÒÃÅȰ, 

Ȱ#ÒÅÁÔÉÖÅ #ÏÍÍÏÎÓȰȟ ÅÔÃȢ). Otherwise, it should be verified under which circumstances it 

is allowed to download and use them.  
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HTML 

2.1. Basics of HTML 

2.1.1. Understand the term Hypertext Markup Language (HTML). 

HTML is a presentational language that we use for the purpose of developing web pages. 

It is a descriptive language used to describe a document's layout, image position, font 

size, font color, etc. HTML is not a programming language, and it cannot complete tasks 

regarding programming (aritmetic or the use of variables), not even the simplest 

program logic such as, for example, the operation of addition. 

HTML pages are nothing but plain text files with HTML. Extension or .htm with 

instructions on how to display a page. Since they are ordinary text files, we can create 

them in any text editor such as, for example, Notepad. There are, of course, more 

advanced versions of visual editors also known as WYSIWYG editors - "What you see is 

what you get." These editors have the ability to display the page layout during the web 

page development. 

To describe a web page we use marked tags, that are written between < i >. Every tag is a 

command that tells the browser how and what to do, or how it should display the 

content. 

 

2.1.2 Understand the role of W3C consortium in making HTML recommendations.  

W3C Consortium is an international organization with the aim of setting standards for 

HTML use. 

Some of the recommendations are: 

ü Websites internal operability on search engines: recommendations on how to use 

HTML to show equally websites in different browsers 

ü Consistent document types declarations: Since international standards are 

applied, it means that we can use any HTML editor to develop a web page. 

ü Enhanced availability: W3C develops recommendations also taking the visually 

impaired into consideration. 

 

2.2.  Using HTML 

2.2.1.  Using browser to view the website source code 

All browsers have the possibility to view a website source code. The image below shows 

how Internet Explorer displays the code. 

Go to View - > Source or right click on the page and select View Source. 
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Afterwards a document will open where we can see the website code. 

 
2.2.2. Use markup tags to structure a  web page layout: <html>, <head>, <title> i <body> 

 

<html> element defines the entire document. It is the root element, and all other 

elements are located within. Like most other elements it has its starting and ending tag 

<html > and < / html >. Since most elements have a final tag, the manual will not 

separately mention it for each element. We will only point out if an element does not 

have an end tag. 

The recommendation is to use <html> tag to insert language tags that search engines 

further use. 

For English language we would therefore define <html lang = ȵeng" >. 

<head> element is used to store metadata, mentioned previously in the manual. 

<title > element is used to define a document's title. This title appears as the title of an 

opened browsers page or when we add a page to Favorites. 

<body> element defines the documentȭs body, and it contains the entire content  such as 

text, images, tables, lists, etc. 

According to HTML5 standard <html >, <body > and <head > tags are not required, but it 

is certainly recommended to use them, since some browsers may produce unpredictable 

results. The problem is, namely, that there is yet no standard applicable to all browsers 

and all their versions.  

Great effort is invested to achieve page layout unification, and this is achieved in newer 

versions of browsers. However, older versions can still lead to incompatibility problems. 
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When creating a website, we should always keep in mind that different users choose 

different  browsers and thus, we should try to create a website that most browsers can 

correctly display. 

2.2.3. Use  markup tag to develop the layout of a web page: <h1>, <p> <br/>, <a href>, 

<img/> 

Tags <h1 > and <h2 > refer to titles within the page. The range of tags goes from <h1 > to 

<h6> and they are arranged according to importance where <h1 > is the title with the 

greatest importance, and < h6 > of least importance. In most cases, we use a maximum of 

<h1 > and <h2 > for titles and subtitles. 

Titles are important since search engines use titles to analyze a page content and by the 

words in the title they analyze what the content might possibly be about. Under no 

circumstance should you use tags for titles to emphasize another text within the page, as 

this could result in reducing the web page ranking in search engines. 

Search engines base their popularity on how accurate their search results are. Any 

attempt to raise the page ranking, using methods that do not comply with the standards, 

is punished by marking the web page as unreliable. 

<p > is the tag for paragraph and we use it to separate particular parts of a text. 

<br/> stands for a line brake. It belongs to a group of tags that do not have a starting and 

ending tag. Therefore, it looks somewhat different and it has the sign / at the end of the 

tag. 

<a href> element consists of tag a that represents a hyperlink that we use as a link to 

another page or some element within the site, and href  tag contains the location to 

which a hyperlink is moving. 

< img / > element is used to include images into a document 

 
The above code would we will see in a web browser as follows: 
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CREATING A WEB PAGE 

3.1. DESIGN 

3.1.1. Recognize planning and design techniques 

As with all jobs, before developing a web page it is necessary to make some planning and 

preparations: 

ü It is necessary to determine the target audience. Namely, the web page with 

information about cooking will be probably significantly different from a web page 

with content for  children. 

ü It is necessary to create a story framework draft; it is necessary to set the main 

guidelines of what the web page will contain 

ü  The page structure has to be well thought through, and it should be easy to 

navigate the page with useful links. 

ü A page layout template is connected to the general page layout. It includes all 

design information such as the table layout, background wallpaper, and the titleȭs 

color. 

ü The navigation scheme allows users to find quickly and easily what they're 

searching for. 

 

           3.1.2. Recognize a good font. Using fonts such as Arial, Courier, Helvetica  

 

Since, in most cases, a text takes up a large part of a web page, selecting a font can have 

a major impact on the design. Generally, there are two types of fonts: Serif and Sans - 

serif. We can see their difference in the following image. Namely, serif fonts have 

additional ornaments on the letters. 

 

 
For the purpose of text  legibility, serif fonts are not recommended for longer texts. 

Instead, they are recommended for titles and similar. 

Arial, Courier, and Helvetica are sans serif fonts representatives and as such they are 

suitable for web page content. Their characteristic is that they look good in almost all 

sizes. 
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3.2 Using the Application  

3.2.1 Open, close a web authoring application. Open, close web pages. 

For the manuals practical part, we use the application KompoZer and you can download it 

for free from http://www.kompozer.net/download.php. Once downloaded the 

application does not require any installation, it is enough to download the content to a 

location of your choice and to start it simply double click kompozer.exe. 

 

 
To close the application, click on X on the applications top right corner. 

To open a web page select File - > Open File and select the desired page from the menu.

 
To close the page, click on X, marked on the image below. 
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3.2.2 Create, save a new web page to a location on  a drive 

To create a new page click File -> New. A dialogue window will open as you can see in the 

following image. Choose option ȵ! ÂÌÁÎË ÄÏÃÕÍÅÎÔȰ and click Create. 

 
To save the page choose File -> Save. If the web page does not have a title, a window will 

appear where you can enter the page title.  Once you enter the title, click OK. 

 
In the next step, a dialogue window will open, where it is necessary to select where you 

want to save the web page, and then choose HTML files for the format. 
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3.2.3 Create, save a new web page based on an available template 

Select File -> New and choose in the window dialogue ȵ! ÎÅ× ÄÏÃÕÍÅÎÔ ÂÁÓÅÄ ÏÎ Á 

templateȰ, then select the template and click on Create. 

 
To save a web page the steps are the same as with 3.2.2. 

 

3.2.4 Add, edit a descriptive web page 

Choose Format -> Page Title and Properties. As shown on the image underneath, a 

dialogue window will open, where you should enter the title, author and description. 

Finallyclick OK. 

 
To view the page click on Browse. This step will open a web browser. 
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3.2.5 The difference between the source code and design view 

Applications at the bottom of the page give us the possibility to change how we view a 

page.  

Clicking on  Source, we view the page code while clicking on the button Preview we can 

see the web page layout (design view). 

 

3.3  Enhancing Productivity 

3.3.1 Set basic preferences in the application: default preview browser, default 

document type, coding, fonts 

Default Browser 

Go to Tools -> Options -> Applications and according to the image below set up the 

desired properties. In this case, we chose Chrome as the default browser. 

 








































































